Foro dedicado el servicio de televisión inteligente TiVo
22 mensajes Página 1 de 2
Hola a todos. Después de pasar un par de días mirando el foro de Serviio, al fin he conseguido reproducir casi todo lo que me interesaba en TIVO (AVI's y MKV's).

Para ello he tenido que mezclar las configuraciones de un par de perfiles (Playstation 3 y Panasonic Viera) y la cosa ha dado sus frutos.

A continuación os detallo el proceso:
- Detened completamente el servidor SERVIIO (botón derecho en el icono de la consola que hay en el área de notificaciones y pulsar sobre Cerrar Serviio
- En C:\Archivos de Programa\Serviio\config hay un archivo llamado PROFILES.XML]
- Copiad el archivo anterior a otra ubicación para conservarlo en caso de error con el que modifiquemos.
- Click con el botón derecho en el archivo profiles.xml y seleccionar Editar.
- Se abrirá el archivo en el Bloc de notas.
- Id al final del archivo.
- Las últimas dos líneas del archivo son </Profile> y </Profiles>.
- Insertad un Enter entre las dos líneas y pegáis el siguiente código:

<Profile id="TIVO-Ono" name="TIVO-Ono" extendsProfileId="1">
<!-- TIVO Ono solo reproduce MPEG2 -->
<Detection>
<HttpHeaders>
<X-AV-Client-Info>.*TIVO.*</X-AV-Client-Info>
</HttpHeaders>
</Detection> <ContentDirectoryMessageBuilder>org.serviio.upnp.service.contentdirectory.PacketVideoDLNAMessageBuilder</ContentDirectoryMessageBuilder>
<MediaFormatProfiles>
<MediaFormatProfile mime-type="video/divx">AVI</MediaFormatProfile>
</MediaFormatProfiles>
<Transcoding>
<!-- Transcode all h264 video with HIGH/MAIN > Level 4.1 on MPEG-TS stream with MPEG2VIDEO and ac3 audio transcoding -->
<Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="384">
<Matches container="*" vCodec="h264" profile="high" levelGreaterThan="4.1" />
<Matches container="*" vCodec="h264" profile="main" levelGreaterThan="4.1" />
<Matches container="avi" vCodec="dvvideo" />
<Matches container="matroska" vCodec="vp8" />
</Video>
<!--
remux MKV with any video to MPEG2TS and possibly change audio to ac3, also AVI and FLV with H264
-->
<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
<Matches container="matroska" />
<Matches container="avi" vCodec="h264" />
<Matches container="flv" vCodec="h264" />
<Matches container="3gp" vCodec="h264" />
<Matches container="mp4" vCodec="h264" />
</Video>
<!-- Remux MPEG-TS with no transcoding -->
<Video targetContainer="mpegts" forceInheritance="true">
<!-- Matches container="avi" vCodec="h264" -->
<Matches container="wtv" />
</Video>
<!-- unsupported codecs will be transcoded into mpeg-ts, mpeg2 video and ac3 audio -->
<Video targetContainer="mpegts" targetVCodec="mpeg2video" targetACodec="ac3" aBitrate="384" DAR="16:9" forceInheritance="true">
<!-- DivX: the following two lines are required for models that do not support DivX: ST60 -->
<Matches container="avi" vCodec="mpeg4" vFourCC="div3,div4,div5,divx,dm4v,dx50" />
<Matches container="avi" vCodec="msmpeg4" vFourCC="div3,div4,div5,divx,dm4v,dx50" />
<Matches container="avi" vCodec="mpeg4" vFourCC="xvid" />
<Matches container="avi" vCodec="msmpeg4" vFourCC="xvid" />
<Matches container="mp4" vCodec="mjpeg" />
<Matches container="mp4" vCodec="dvvideo" />
<Matches container="mp4" vCodec="mpeg4" />
<Matches container="mpeg" vCodec="mpeg1video" />
<Matches container="matroska" vCodec="mpeg4" />
<Matches container="matroska" vCodec="vp8" />
<Matches container="asf" />
<Matches container="ogg" />
<Matches container="rm" />
</Video>
<!-- unsupported audio will be transcoded into lpcm audio -->
<Audio targetContainer="lpcm" forceInheritance="true">
<Matches container="ogg" />
<Matches container="asf" />
<Matches container="adts" />
<Matches container="wavpack" />
<Matches container="mpc" />
<Matches container="ape" />
</Audio>
</Transcoding>
<Subtitles>
<SoftSubs mime-type="text/srt" />
<HardSubs>
<RequiredFor container="mp4" />
</HardSubs>
</Subtitles>
<ThumbnailsResolution>HD</ThumbnailsResolution>
</Profile>


- Una vez copiado todo lo anterior se guarda el archivo.
- Reiniciar Serviio Menú Inicio\Todos los Programas\Serviio\Start Serviio Service.
- Ejecutar consola Serviio Menú Inicio\Todos los Programas\Serviio\Serviio Console
- En la consola, haced clik sobre Detener servidor
- En la ventana de Perfil de Ripper seleccionar el perfil TIVO-Ono para la IP del deco.
- En la pestaña entrega, marcad la casilla Habilitar transcodificación.
- Haced click en Guardar.
- Haced click en Iniciar Servidor.

Ahora ya podéis probar en vuestro TIVO que archivos reconoce y cuales no.

Entre todos, y mirando un poco el código, seguro que podremos completarlo y mejorarlo para poder usar esta función del TIVO mientras no reconozca los archivos por sí mismo.

Saludos.
El que afloja peleando, termina por morir.
Una pregunta se podria hacer con un portatil esto conectado al tivo directamente?

Enviado desde mi GT-I8160 usando Tapatalk 2
jtl escribió: Una pregunta se podria hacer con un portatil esto conectado al tivo directamente?


Hasta donde yo sé, todo tiene que estar en red, por lo que no creo que la conexión directa sea válida.
El que afloja peleando, termina por morir.
txus escribió:
jtl escribió: Una pregunta se podria hacer con un portatil esto conectado al tivo directamente?


Hasta donde yo sé, todo tiene que estar en red, por lo que no creo que la conexión directa sea válida.

Me a reconocido el portatil el tivo creo que ya lo tengo pero no me funciona

Enviado desde mi GT-I8160 usando Tapatalk 2
Para todo esto que comentáis tiene que estar el ordenador encendido no?
"Sé positivo, pierde un electrón"
Yippee-ki-yay escribió: Para todo esto que comentáis tiene que estar el ordenador encendido no?


El que afloja peleando, termina por morir.
Ya lee avi,ahora a ver si alguien con conocimientos consigue que lea mp4.
Imagen
Imagen
Imagen
Hola. Después de haber estado cacharreando con la aportación de Txus (muchas gracias, por cierto), he descubierto que, añadiendo una línea más al código que nos proponía, conseguimos reproducir los mp4. La flauta ha sonado por casualidad, porque mis conocimientos son casi nulos pero el caso es que ha funcionado. Tenemos que añadir:
<Matches container="mp4" vCodec="h264" />
en el apartado <!-- remux MKV with any video to MPEG2TS and possibly change audio to ac3, also AVI and FLV with H264 -->

quedando así:
<!--
remux MKV with any video to MPEG2TS and possibly change audio to ac3, also AVI and FLV with H264
-->
<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
<Matches container="matroska" />
<Matches container="avi" vCodec="h264" />
<Matches container="flv" vCodec="h264" />
<Matches container="3gp" vCodec="h264" />
<Matches container="mp4" vCodec="h264" />
</Video>

La negrita y el subrayado son para que destaque el texto dentro del código y se vea dónde hay que pegarlo.
Vaya novedad ojala se quedara para siempre sin requerir un pc

Enviado desde mi GT-I8160 usando Tapatalk 2
jtl escribió: Vaya novedad ojala se quedara para siempre sin requerir un pc

Enviado desde mi GT-I8160 usando Tapatalk 2

Me parece que vas un poco despistado, para visualizar archivos vía DLNA SIEMPRE necesitaras un dispositivo externo que haga de servidor, Tivo solo reproduce ciertos formatos y contenedores y es trabajo de ese servidor proporcionarle los archivos en un formato que Tivo entienda.
Aquí no se trata para nada de lo que pueda reproducir vía USB.
Axel escribió: Hola. Después de haber estado cacharreando con la aportación de Txus (muchas gracias, por cierto), he descubierto que, añadiendo una línea más al código que nos proponía, conseguimos reproducir los mp4. La flauta ha sonado por casualidad, porque mis conocimientos son casi nulos pero el caso es que ha funcionado. Tenemos que añadir:
<Matches container="mp4" vCodec="h264" />
en el apartado <!-- remux MKV with any video to MPEG2TS and possibly change audio to ac3, also AVI and FLV with H264 -->

quedando así:
<!--
remux MKV with any video to MPEG2TS and possibly change audio to ac3, also AVI and FLV with H264
-->
<Video targetContainer="mpegts" targetACodec="ac3" aBitrate="384">
<Matches container="matroska" />
<Matches container="avi" vCodec="h264" />
<Matches container="flv" vCodec="h264" />
<Matches container="3gp" vCodec="h264" />
<Matches container="mp4" vCodec="h264" />
</Video>

La negrita y el subrayado son para que destaque el texto dentro del código y se vea dónde hay que pegarlo.


Lo incluyo en el inicio del post. Muchas gracias Axel
El que afloja peleando, termina por morir.
Gracias Txus, he conseguido ver sin problemas mkv y otros en mi tivo. :)
También me funcionó serviio en mi smart tv, un LG LM860V, sin embargo el fallo principal que encuentro tanto en tivo como en la tv es que después de parar un video no da opción a reanudar donde se había quedado. Supongo que esta opción depende del reproductor dlna de cada aparato y no se puede arreglar.
Saludos.
Charly escribió: Gracias Txus, he conseguido ver sin problemas mkv y otros en mi tivo. :)
También me funcionó serviio en mi smart tv, un LG LM860V, sin embargo el fallo principal que encuentro tanto en tivo como en la tv es que después de parar un video no da opción a reanudar donde se había quedado. Supongo que esta opción depende del reproductor dlna de cada aparato y no se puede arreglar.
Saludos.

En el Tivo no se puede reanudar desde una posición anterior, pero al menos en mi modelo de LG no tengo ningún problema en empezar desde donde lo deje de ver.
No conocía Serviio pero seguro que a partir de ahora se convierte en una función obligatoria de cualquier ordenador que me pille.

MUCHAS GRACIAS!!
Perdonar mi ignorancia, pero para poder conectar el Tivo con el PC hay que hay que hacerlo mediante cable Ethernet, (o en su defecto un conversor de ethernet a Wifi ) hasta el cable modem.
Yo no tengo ningun cable ni conversor.
La preguna es, ¿porque cuando desde las opciones de red de decodificador doy a buscar red me aparece la direccion IP del cable modem?

PD: se puede hacer un tutorial o algun enlace que explique el proceso?
22 mensajes Página 1 de 2

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 2 invitados